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JobMaker Hiring Credit 
The JobMaker Hiring Credit will give businesses incentives to take on additional young job 
seekers. This will help young people access job opportunities as the economy recovers. 
 
Employers may seek guidance about employer and employee eligibility from the JobMaker 
Hiring Credit for business website: ato.gov.au/jobmakerhiringcredit 
 

Overview 
JobMaker Hiring Credit duration and periods 

• The JobMaker Hiring Credit (JMHC) measure started on 07 October 2020 and will run 
through to 06 October 2022. 

• Employees commencing employment prior to 07 October 2020 or after 06 October 
2021 are not covered by the scheme and cannot be claimed for. 

•  
JobMaker period JobMaker period dates Claim period dates 

Period 1 07 October 2020 to 06 January 2021 01 February 2021 to 30 April 2021 

Period 2 07 January 2021 to 06 April 2021 01 May 2021 to 31 July 2021 

Period 3 07 April 2021 to 06 July 2021 01 August 2021 to 31 October 2021 

Period 4 07 July 2021 to 06 October 2021 01 November 2021 to 31 January 2022 

Period 5 07 October 2021 to 06 January 2022 01 February 2022 to 30 April 2022 

Period 6 07 January 2022 to 06 April 2022 01 May 2022 to 31 July 2022 

Period 7 07 April 2022 to 06 July 2022 01 August 2022 to 31 October 2022 

Period 8 07 July 2022 to 06 October 2022 01 November 2022 to 31 January 2023 

 

JobMaker Hiring Credit rates 
Through the JobMaker Hiring Credit payment scheme, eligible employers will be eligible to 
receive payments of up to: 

• $200 a week – for each eligible additional employee aged 16 to 29 years old 
(inclusive). 

• $100 a week – for each eligible additional employee aged 30 to 35 years old 
(inclusive). 

An employee’s age is calculated based on the commencement date the employer reports via 
the STP payroll event. There is no requirement for an employer to report the rate they think 
they will get for their employees; this will be calculated by the ATO based on the 
information received. Amounts paid to employers will be capped by relative changes in 
headcount and payroll over time, please refer to: 
ato.gov.au/jobmakerhiringcreditguide for information regarding this. 
 
 
 
 
 
 
 

https://ato.gov.au/jobmakerhiringcredit
https://ato.gov.au/jobmakerhiringcreditguide
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JobMaker Hiring Credit claim cycle 
The claim process for the JobMaker Hiring Credit is every three months in arrears from 01 
February 2021 to 31 January 2023. A claim for an eligible employee can only be made for a 
period of up to 12 months after their commencement of employment with the employer, or 
until the STP reported cessation date, whichever comes first. 
The JobMaker Hiring Credit claim process will be online via ATO Online services and will not 
be managed via STP. 
Claims and amendments to claims must be undertaken within the claim period for each 
JobMaker period. 
 
To be eligible for the JobMaker Hiring Credit you must report your nominations and 
minimum hours test declaration via STP (in WorkDESK). 
 

Setting up in WorkDESK 
 
The setup for JobMaker in WorkDESK is very similar to JobKeeper, where you setup special 
allowances and put them on the nominated (eligible) employees with a 0.01 amount. 
 
You must use the STP payroll event to nominate employees eligible for the JobMaker Hiring 
Credit to the ATO. 
Reporting of employees who have been nominated for the JobMaker Hiring Credit is 
expected to occur at the point of hiring during the JobMaker period dates, and prior to 
making a claim, noting it may take up to 72 hours for this information to be processed and 
made available for JobMaker Hiring Credit purposes. 
 
To nominate an employee the following items must be up to date before completing the 
STP payrun. 
Payee TFN – in File -> Employee -> View -> Taxation: TFN 
Payee Commencement Date – in File -> Employee -> View -> Main: Date Commenced 
Payee Date of Birth – in File -> Employee -> View -> Main: Date of Birth 
 
WorkDESK ATO Reportable allowances ('Separate on PAYG Summary’ flag) are to be used 
for JobMaker reporting.  

Each nominated Employee will require an allowance for Nominating or Renominating the 
employee, and for any Periods (up to 8) that they meet the minimum hours test. 

1) JobMaker Hiring Credit nomination - JMHC-NOM 

• A special allowance used to indicate the JobMaker Hiring Credit nomination for the 
employee. 

• Employees are only required to be nominated once under the scheme, and there is 
no requirement to report this more than once for an employee. 
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2) JobMaker Hiring Credit minimum hours test - JMHC-P## 

• You must inform the ATO via an STP payroll event when an employee that you have 
nominated has met the minimum hours test for a JobMaker period that you intend 
to claim for.  

• You will need to report this quarterly that they met the eligibility criteria. 

• Reporting of an employee meeting of the minimum hours test is expected to occur 
at the point where you have confirmed the employee has met the test for the 
period, and prior to making a claim for the period, noting it may take up to 72 hours 
for this information to be processed and made available for JobMaker Hiring Credit 
purposes. 

• Your declaration that the employee has met the minimum hours test for each period 
must be reported as a special allowance code ‘JMHC-P##’ where ## refers to the 
JobMaker period the test was met in. 

• You are only required to report a period once per employee. 

• Each JobMaker period has its own unique code: 

JobMaker period Other allowance type description 

Period 1 JMHC-P01 

Period 2 JMHC-P02 

Period 3 JMHC-P03 

Period 4 JMHC-P04 

Period 5 JMHC-P05 

Period 6 JMHC-P06 

Period 7 JMHC-P07 

Period 8 JMHC-P08 

 

3) JobMaker Hiring Credit cessation 

• If an employee who has been nominated for JobMaker Hiring Credit ceases 
employment within 12 months of being hired, you must inform the ATO of this via an 
STP payroll event.  

• A ‘Payee cessation date’ must be reported via a termination payment A070 – if you 
require to report a cessation date for a JobMaker & have not used A070 please 
contact support. 
 

4) JobMaker Hiring Credit rehire nomination - JMHC-RENOM 

• Where an employee ceased employment and is subsequently rehired and meets the 
eligibility criteria for the JobMaker Hiring Credit then you can nominate the 
employee again by reporting a special allowance code with an ‘Other Allowance 
Type Description’ of ‘JMHC-RENOM’.  

• The appropriate commencement date for the rehire must be reported and the date 
of birth of the employee must also be reported. 

• When reporting a rehire nomination the commencement date of the rehire must not 
be prior to the cessation date of the original nomination. 

• A rehire nomination cannot be reported if a cessation date has not been reported for 
the original nomination. A ‘JMHC-NOM’ or ‘JMHC-NOMX’ (see corrections) cannot be 
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reported where there is an active and valid ‘JMHC-RENOM’ subsequently reported 
for the employee. 

• The design for rehires does not support multiple rehires after one rehire, should this 
occur, you will need to contact the ATO directly to manage this situation. 

 

Corrections  
Other allowance type description for removal of previously reported information. These are 
not required unless you need to make a correction. 
 
5) Remove the nomination for an employee - JMHC-NOMX 

• A special 'Other' type allowance code ‘JMHC-NOMX’ will remove the nomination for 
the employee, and they will not be part of any claim. 

• This should only be used to indicate that the original nomination should not have 
been provided. It is not to be used to report the cessation of an employee, this 
should be reported using a cessation date. 
 

6) Remove the rehire nomination for an employee - JMHC-RENOMX 

• A special 'Other' type allowance code ‘JMHC-RENOMX’ will remove the rehire 
nomination for the employee, and they will not be part of any claim. 

• This should only be used to indicate that the rehire nomination should not have 
been provided. It is not to be used to report the cessation of an employee, this 
should be reported using a cessation date. 

7) Remove the declaration that an employee met the minimum hours test for a specific 
period – JMHC-P##X 

• This will remove the declaration that an employee met the minimum hours test for 
the specific JobMaker period indicated in the cod (##) e.g. JMHCP01X to remove if an 
employee was incorrectly reported for Period 1. 
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Configuring in WorkDESK:  
The following screens are examples of Allowances and General Ledger code setup. 

Add a new GL code to keep JobMaker reported allowances separate  
Add this somewhere in your balance sheet or discuss with your accountant for the best 

place to put this in your WorkDESK General Ledger. 

  
 

• WorkDESK requires you to enter 0.01 against any JobMaker special allowances.  
This will keep track separately in the GL of any 0.01 payments 
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Adding in New Allowance Codes 
1) JobMaker Hiring Credit nomination - JMHC-NOM 
 

 
Red = Mandatory Fields 
Yellow = optional or user customisable fields. 
 
Allowance Code: A520 - use any free available allowance code greater than A200.  

• We recommend you use A599 or less as this will automatically stop the allowance 
reported with an amount next pay. If you use A600 or above, after paying an 
employee you must manually set the amount to 0 on the employee allowances 
screen. 

• Short Name: JMHCN - only shows on some WorkDESK reports where a short 
description is needed to fit on a print out. 

• Description: JMHC-NOM Used for WorkDESK reports 

• Pay/ Deduct Basis: Amount 

• Separate on PAYG Summ: Yes 

• Taxable: No 

• Pay during Holidays?: No 

• Add to Super for OTE?: No 

• General Ledger code: Suggest you add a new GL code to keep track of the JobMaker 
Payments - somewhere in your balance sheet. Otherwise contact your accountant. 

• Reportable Type: Top right box 'Other' 

• Reportable Description: JMHC-NOM 
It is mandatory that the Reportable Description matches exactly as is written here. 
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2) JobMaker Hiring Credit minimum hours test - JMHC-P## 
To report when an employee you have nominated has met the minimum hours test for a 
JobMaker period that you intend to claim for. 

 
Red = Mandatory Fields 
Yellow = optional or user customisable fields. 
 
Allowance Code: A521 - use any free available allowance code between A200 and A600.  

• Use a code less than A600 as this should only be reported once per employee 

• Short Name: JMHCP1- only shows on some WorkDESK reports where a short 
description is needed to fit on a print out 

• Description: JMHC-P01 Used for WorkDESK reports 

• Pay/ Deduct Basis: Amount 

• Separate on PAYG Summ: Yes 

• Taxable: No 
Pay during Holidays?: No 

• Add to Super for OTE?: No.  

• General Ledger code: Use the same GL code as your JobMaker Hiring Credit 
nomination code 

• Reportable Type: Top right box 'Other' 
Reportable Description: JMHC-P01 
It is important that the Reportable Description matches exactly as is written here. 

• You will be required to add separate allowance codes for different JobMaker 
Periods. 
e.g. use A522 for Period 2, and set the description for it to JMHC-P02 
 

You are not required to add all periods (1 to 8) immediately, but we recommend you add them now 
so you don’t need to set them up later on. 
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Example of JobMaker Period 2: 

  
Where the Allowance code, Short Name, ‘Other’ and ‘Description’ has changed to 2. 
Repeat this for all periods up to and including 8. 
 

3) JobMaker Hiring Credit cessation 
No allowance code is required but you must set the Employee to Terminated in File -> Employee -> 

Maintain -> Main: set Pay Frequency to ‘Terminated’. 
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4) JobMaker Hiring Credit rehire nomination - JMHC-RENOM 

Where an employee ceased employment and is subsequently rehired and meets the 

eligibility criteria for the JobMaker Hiring Credit. 

 
Red = Mandatory Fields 
Yellow = optional or user customisable fields. 
 
Allowance Code: A530 - use any free available allowance code greater than A200.  

• Short Name: JMHCRN - only shows on some WorkDESK reports where a short 
description is needed to fit on a print out. 

• Description: JMHC-RENOM Used for WorkDESK reports 

• Pay/ Deduct Basis: Amount 

• Separate on PAYG Summ: Yes 

• Taxable: No 

• Pay during Holidays?: No 

• Add to Super for OTE?: No 

• General Ledger code: Use the same GL code as previous JobMaker allowances. 

• Reportable Type: Top right box 'Other' 
Reportable Description: JMHC-RENOM 
It is mandatory that the Reportable Description matches exactly as is written here. 
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Corrections Allowances 
You can add these now or only if they are required (e.g. you need to make an amendment/ 
correction for an incorrect employee or period). 
 
 
5) Remove the nomination for an employee - JMHC-NOMX 
This is used to remove the nomination for the employee, and they will not be part of any 
claim. 

 
Red = Mandatory Fields 
Yellow = optional or user customisable fields. 
 
Allowance Code: A529 - use any free available allowance code greater than A200.  

• Short Name: JMHCNX - only shows on some WorkDESK reports where a short 
description is needed to fit on a print out. 

• Description: JMHC-NOMX Used for WorkDESK reports 

• Pay/ Deduct Basis: Amount 

• Separate on PAYG Summ: Yes 

• Taxable: No 

• Pay during Holidays?: No 

• Add to Super for OTE?: No 

• General Ledger code: Use the same GL code as previous JobMaker allowances. 

• Reportable Type: Top right box 'Other' 
Reportable Description: JMHC-NOMX 
It is mandatory that the Reportable Description matches exactly as is written here. 
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6) Remove the rehire nomination for an employee - JMHC-RENOMX 
This will remove the rehire nomination for the employee, and they will not be part of any 
claim. 

 
Red = Mandatory Fields 

Yellow = optional or user customisable fields. 

 

Allowance Code: A529 - use any free available allowance code greater than A200.  

• Short Name: JMHCRX- only shows on some WorkDESK reports where a short 
description is needed to fit on a print out. 

• Description: JMHC-RENOMX Used for WorkDESK reports 

• Pay/ Deduct Basis: Amount 

• Separate on PAYG Summ: Yes 

• Taxable: No 

• Pay during Holidays?: No 

• Add to Super for OTE?: No 

• General Ledger code: Use the same GL code as previous JobMaker allowances. 

• Reportable Type: Top right box 'Other' 
Reportable Description: JMHC-RENOMX 
It is mandatory that the Reportable Description matches exactly as is written here. 
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7) Remove the declaration that an employee met the minimum hours test for a specific 
period – JMHC-P##X 
This will remove the declaration that an employee met the minimum hours test for the 
specific JobMaker period indicated in the cod (##) e.g. JMHCP01X to remove if an employee 
was incorrectly reported for Period 1. 

 
Red = Mandatory Fields 

Yellow = optional or user customisable fields. 

 

Allowance Code: A529 - use any free available allowance code greater than A200.  

• Short Name: JMP01X - only shows on some WorkDESK reports where a short 
description is needed to fit on a print out. 

• Description: JMHC-P01X Used for WorkDESK reports 

• Pay/ Deduct Basis: Amount 

• Separate on PAYG Summ: Yes 

• Taxable: No 

• Pay during Holidays?: No 

• Add to Super for OTE?: No 

• General Ledger code: Use the same GL code as previous JobMaker allowances. 

• Reportable Type: Top right box 'Other' 
Reportable Description: JMHC-P01X 
It is mandatory that the Reportable Description matches exactly as is written here. 
 
 
 
 
 
 



JobMaker in WorkDESK Version 1.0 
 

Page | 13 
 

 
Example Period 2 

 
 
  



JobMaker in WorkDESK Version 1.0 
 

Page | 14 
 

 

Adding Allowances to Employees 

1) Adding JobMaker Nomination Allowance 

Add the JobMaker Hiring Credit allowance code to the File -> Employee -> Enter/ Alter 
Allowances/ Deductions with the Total Amount as 0.01 

 
Press ‘Save’. 
This must be done once per nominated employee. 
Leave this will report the employee in the next payrun. Otherwise, if you must report now 
you can do an adjustment payrun using the A060 allowance code (see section 3 below). 
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2) Report the period where the employee has met the minim hour test 
This allowance must be added when you know the employee has met the minimum hours, it 
may be at a later time, after you’ve nominated the employee. 
Determine which Period to report for the employee based on the information given 
previously in this document. An Employee can have up to 8 periods reported. 

 
This is an example only, you need to determine which Periods you should report for each 
employee.  
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3) If the employee has no other pay and you need to report now  
If no other timesheets/ gross is being paid in this Payrun to the employee i.e. you’ve 
determined the minimum hours test and must send this through STP before their next pay, 
then you must enter in an Adjustment allowance A060 on the employee. 
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4) Processing the Employee Pay 
 

Processing the Payrun 

If the employee is not being paid and you need to report the Period/ Nomination now then 
this needs to be processed through an Adjustment Payrun. 

  
Otherwise process the Payrun as normal. 
Confirm the Excel Reports that the correct JobMaker allowances are reporting for each 
applicable employee. 
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Single Touch Reporting 

Following the above steps (allowance setup and adding to employees) should result in the 
STP Excel reports during the Payrun including these reportable allowances. 
 

 
e.g. you should see the JobMaker Nomination allowance code JMHC-NOM reporting a 0.01 
period amount if you have set it up report this pay.  
 
When you are processing for additional JobMaker Periods with allowances  you should 
expect to see another line with that period number in the allowance description. (e.g. 
period 2 will show on another line). 
Previously reported allowances will continue to show with 0 in the Period Amount and 0.01 
in the YTD Amount columns. 
 
 
Confirm the expected allowances are appearing before proceeding.  
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Corrections 
The ATO will treat JobMaker Hiring Credit allowance code reporting in chronological order of when 

the payroll report is lodged. 

For example, if an employee reports ‘JMHC-NOM’ for an employee, then cancels by reporting 

‘JMHC-NOMX‘ to remove the nomination, they can subsequently use the ‘JMHC-NOM’ code again 

for that employee (with relevant mandatory fields) to nominate the employee once more. Please 

note any amendments for the claim for the JobMaker Hiring Credit must be made within the claim 

period for each JobMaker period. 

Remove nomination or minimum hours declaration 
The design for the JobMaker Hiring Credit using the Other Allowance Type Description caters for the 

removal of previously reported JobMaker Hiring Credit information. This is handled by adding an ‘X‘ 

to the Other Allowance Type Description previously reported: 

 

5) Remove the Nomination for the employee 

In File -> Employee -> Enter/ Alter Allowances input the allowance code for JMHC-NOMX 

 
With Total amount as 0.01 and save. 

 

6) Remove the Rehire Nomination for the employee  
Repeat the same as above if you are required to remove a Rehire Nomination using your JMHC-
RENOMX allowance code. 
 
 

7) Remove the declaration that an employee met the minimum hours test for the specific 
JobMaker period indicated in the code 
Repeat the same as 5, but with the specific JobMaker Period X code. E.g. JMHC-P01X to remove a 
declaration for period 01. 
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