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Introduction
Single Touch Payroll (STP), is an Australian Government initiative to reduce employers' reporting
burdens to government agencies.
In the 2019–20 Budget it was announced the ATO would expand the data collected through STP.
This expansion of STP (also known as STP Phase 2) reduces the reporting burden for employers who
need to report information about their employees to multiple government agencies. It also supports
the administration of the social security system.
Employers will report the additional information through STP on or before each pay day.
The mandatory start date for WorkDESK STP Phase 2 reporting is 1 May 2022.
If you need more time to transition:
You'll be able to apply for a delayed transition from December 2021. Registered agents will also be
able to apply. More information will be available on the ATO website soon.
There won't be penalties for genuine mistakes for the first year of Phase 2 reporting until 31
December 2022. This includes employers who have already started Phase 2 reporting.

ATO Employer Guide
The STP Phase 2 employer reporting guidelines helps outline what is required for reporting through
STP Phase 2. This is recommended reading before activating STP Phase two in WorkDESK.
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Software Upgrade and Requirements
To facilitate the expansion of the STP Reporting data, WorkDESK now requires a bridge database in
SQL to store all the additional STP Phase 2 reporting information and a Windows service to connect
WorkDESK to the SQL Database.
With assistance from your IT Support and/ or WorkDESK Support, SQL Server can be installed on
your existing WorkDESK server to host this bridge database. SQL Server does not require a licence to
install & use in these circumstances.
A separate WorkDESK.123-STP2 Service is also required to be installed on the machine where SQL
Server is installed. This service must be installed & configured prior to pre-activating and activating
STP Phase 2.
More details of the SQL Server and WorkDESK.123-STP2 Service installation are available in the 123STP2 Service Installation notes. This must be done prior to Pre-activating and Activating STP2 in
WorkDESK. Pre-Activation will fail if this service installations is not done first.
When you install the WorkDESK Update 12.5100 or higher, these notes will be made available in
your Tempsys\Help folder as well as well as on our Software updates website for the 12.5100
Upgrade.

Once the WorkDESK.123-STP2 Service is configured and installed, the rest of the setup and
activation for STP Phase two is done through WorkDESK (similar to the process for the original STP)
and details are included in this document.
An internet connection is still required when making a STP2 submission. All the actions required to
make a submission are completed within WorkDESK screens – you do not need to access anything
outside of the WorkDESK environment except for access to the Machine Credential that will be used
to sign the submission.
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Key Changes for STP Phase 2
The rest of the notes and setup require you to be familiar with the new terminology for STP Phase 2.
Each section below contains a link to the relevant area in the ATO’s STP Phase 2 employer reporting
guidelines
The key changes to the STP reporting include:
•
•
•
•

Disaggregation of gross
Employment and taxation conditions
Income types
Country codes

Disaggregation of gross
Your STP report currently includes a gross amount. This is the total of many different components
and payment types. Because some of these are treated differently for social security purposes, you
will now need to report more detail.
See also: Disaggregation of gross

Employment and taxation conditions
There are many factors that influence how you manage your employees in your payroll. These
include:
•
•
•

their employment basis
the information on their TFN declaration
details of when and why they leave.

You currently provide this information in different ways and on different forms.
Phase 2 streamlines this process by including the information in your STP report.
See also: How to report employment and taxation information through STP Phase 2

Income types
You already tell the ATO about the type of income your employees receive in your STP report.
The reporting of income types is being introduced in Phase 2 to more flexibly:
•
•
•

identify payments you make to your employees with specific tax consequences
make it easier for them to complete their individual income tax return
help the ATO identify where you are using a concessional reporting arrangement.

Country codes
Sometimes you'll need to report a country code. For example, if you make a payment to an
Australian resident working overseas, you'll need to provide information about the host country.
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Before Activating STP Phase 2 in WorkDESK
STP Phase 2 requires Pre-Activation for you to transition your existing STP information. While preactivating, new screens will be available in WorkDESK to configure these new changes.
These changes will not be sent to the ATO until you have fully activated STP Phase 2 so you can
complete the pre-activation steps in your own time.
Once you have completed the Pre-Activation process & checked your configuration you can activate
STP 2 and start reporting the new information.
Pre-Activation process:
•
•

Pre-Enable STP2 – enables the screens for you to configure the new changes.
Review STP Configuration – Review or change any employee, allowance or pay details prior
to activation.

Pre-Enable STP2
1) WorkDESK 12.5100+ and the WorkDESK-123.STP Service must be installed and running prior
to starting the pre-activation. See Software Upgrade and Requirements section for more
details.
2) Enable Pre-Activation in WorkDESK
We recommend having all other users logged out for the duration of pre-activation.
Perform a zip online backup.
Go into System -> System Control -> Maintain System Control File -> Company Information

Press Pre-Enable STP2. Activation should occur quickly.

And Press Ok.
Repeat this step for every WorkDESK database you require to report STP information.
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Review STP Phase 2 Configuration
During the Pre-Enable, WorkDESK will set to default as much as it can (e.g. Employee Income Types
or Employment Basis), some other information will require your input, in yellow, or you to change if
the defaults were not correct in your circumstances.
Below covers all the new fields and screens in WorkDESK that you should review for STP Phase 2
reporting.
Defaults made during the pre-enable are noted as Pre-Activation Default: in this section.
Note: There won't be penalties from the ATO for genuine mistakes for the first year of Phase 2
reporting until 31 December 2022.

Employee Details
File -> Employee -> Maintain -> Taxation:

Income Type: Defaults to Salary and Wages (SAW) for all employee’s except if using tax scale 15
where it will default to Working Holiday Maker (WHM).
CHP is for Closely Held Payees, if you are using the concessions available to closely held payees, you
must report these payments under this income type & change it manually.
Pre-Activation Default: All non- Working Holiday Maker employees are set to income type SAW –
Salary and Wages.
Working Holiday Makers are defaulted to Income Type WHM.
If the employee should be a CHP type you must change it manually.
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Country Code: Only required for WHM type employees - you must provide information about their
home country before you can save.
Pre-Activation Default: No default is selected, for each WHM type employee, you must input their
Country manually first in File -> Employee -> Maintain -> Taxation: Country drop down box.
Employment Basis: Defaults to Casual if Employee Pay Frequency is Casual or Permanent for all
other types (Weekly, monthly, etc).
This employment basis field is generally what the employee has filled out on their Tax File
Declaration form – Question 7, but it can be updated to better reflect their current employment
details.
Pre-Activation Default: For all current casual type employees their Employment basis are set to
Casual.
For all permanent type employees (e.g. weekly, Monthly, etc) are set to Full Time.
Tax Treatment Code:
This is generated automatically during the payrun update or STP Update submission.
This is derived by the details entered in the Employee -> Taxation screen. Ensure this is up to date or
correct if the employee’s details change.

Date Commenced: You are not required to update this date now for employees but moving forward
here are some details from the ATO about using this date when rehiring employees:
The start of the employment or engagement relationship between the payer and the employee. The
commencement date must reflect the earliest recognised start date for the continuous
employment/engagement period of service with the payer or related entity.
If the employee is rehired using the same payroll id the rehire commencement date should be
reported (only if the employee was terminated and rehired under a different reporting period).
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Termination date and Reason:
If you set the employee to Terminated or set them to ‘Terminate after next pay’ (in the ‘Other’ tab)
or pay a termination payment (Allowance A070) you are prompted to input their termination
(cessation) date and reason.

Cessation Date:
This is labelled as Termination Date in WorkDESK.
It will default to the date on which you set the employee to terminated in File -> Employee ->
Maintain -> Main: Pay Frequency set to Terminated.
If you do not set your employees to terminated, a Cessation date will not be reported.
To change the date go into File -> Employee -> Maintain -> Other:
Cessation Type:
No Default Cessation Type is set and must be set manually after pre-enabling.
You must set for each terminated employee their type in File -> Employee -> Maintain -> Other.
To build a list of terminated employees go into Reports -> Payroll -> Employee -> PAYG Payment
report and export to Excel and filter by the ‘Pay Freq’ column for any Term types.
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Allowances
In Accounting -> Payroll -> Allowances are fields to classify WorkDESK Allowances.
Reportable Allowances and STP Payment Type. One of each needs to be defined for each
allowance.
Note Allowances A199 or less are system allowances and will have their own definition set, so you
are not required to check these Allowances (e.g. A010 Annual leave is automatically controlled).

ATO Reportable Allowances
The definition and usage for reportable allowances have changed:
ATO Reporting Guidelines – Allowances.
Example Meal Allowance Setup:

The allowance types you will separately report in STP Phase 2 are:
> cents per km (allowance type CD)
> award transport payments (allowance type AD)
> laundry (allowance type LD)
> overtime meal allowance (allowance type MD)
> domestic or overseas travel (allowance type RD)
> tool allowances (allowance type TD)
> qualification and certification allowances (allowance type QN)
> task allowances (allowance type KN)
> other allowances (allowance type OD)
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Pre-Activation Default:
STP to STP2 Reportable Allowances
Before

After

In the above example, a Car expense from STP1 is adjusted to a CD Cents per Kilometre allowance
for STP2.
Previous Reportable allowances will be converted as below:
STP
Car expense
Transport
Laundry
Meals
Travel
Other

STP2
CD – Cents Per KM
AD – Award Transport Payment
LD – Laundry
MD – Overtime Meal
RD – Domestic or Overseas Travel.
OD – Other

If this conversion doesn’t match your definition for an allowance, you can change it now before
activating STP2 payruns.
You can change the type after activating STP2 and processing payruns but changing if an employee
was paid against it will require you to create an Update File to send the changes to the ATO - see
Corrections – Misclassification section for more details.
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STP2 Disaggregated Gross Allowances

This is for all other allowance that don’t fit the ATO’s ‘separate allowance’ definition as part of the
Disaggregation of Gross.
You may be using a WorkDESK allowance code for something that isn’t defined as a ‘separate
allowance’ by the ATO’s definition & here you can configure how it should be reported.
The STP Payment Type field is enabled for this use of other Disaggregated Gross items. E.g. a
WorkDESK allowance could be used as a Bonus, Workers’ Compensation. Or it meets the Gross
definition and can be set as such.
> gross
> overtime
> bonuses and commissions
> directors’ fees
> paid leave P, W, A, C, U or O.
Note: Paid Leave types C, U and O are covered by WorkDESK System allowance codes. We
recommend you continue to use the system allowance codes (e.g. A010 for paying Annual Leave,
A020 for Personal leave, A070 for Unused Leave on termination, etc) as they will track against the
employees leave register. These Paid Leave types are available here if adjustments are required or
you have a special circumstance.

Not Reportable is available for things like reimbursements that are not required to be reported
through STP.
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Pre-Activation Default:
All other allowances (Reportable Allowances set to No) will default based on the Taxable? And Add
to OTE for Super? flags.
Taxable Yes and OTE for Super Yes = Gross. E.g. Current year back payment.
Taxable Yes and OTE for Super No = Overtime. E.g. Toil Cash Out.
Taxable No and OTE for Super No = Do not report. E.g. A reimbursement.
Example: this allowance was set to Taxable Yes and OTE Yes: will result in STP Payment Type: Gross.

Allowances you have that don’t meet these defaults must have the STP Payment Type changed
manually.
Lump Sum E payments:
No year is recorded prior to STP 2, if you made any Lump Sum E payments this financial year prior to
STP 2 activation please contact support to assist specificizing a Lump Sum E year/s for your
transitioned data.
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Billing Multipliers

These relate to the specific rate lines on the Job Order 1 to 4.
These should be set to Gross if Add to OTE for Super is ‘Yes’, otherwise set to Overtime.
Unless the rate line you want to use is specifically for Workers’ Compensation, which you can set
manually for a specific Billing Multiplier code if you have a job setup for Workers’ comp payments.
If your rate lines require more definitions, you may need to use a Rate Book instead.
Pre-Activation Default:
Add to OTE for Super? ‘Yes’ will be set to STP Payment Type Gross.
Add to OTE for Super? ‘No’ will be set to STP Payment Type Overtime
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Rate Books

A new column is available on the Rate Book Add and Alter Screen as STP Payment Type
Note if you want to resize the window like above select Window -> Resize Screens from the top menu.
In most cases if you’ve selected OTE? As ‘Yes’ the STP Payment Type is Gross, if ‘No’ the Payment
Type is Overtime.
You also have the choice if a particular pay item is a Bonus, Directors’ Fees, Workers’ Comp, etc.
STP Separate Allowance items are also available per rate line, E.g. Cents Per Kilometre.
> gross
> overtime
> bonuses and commissions
> directors’ fees
> paid leave P, W, or A
> cents per km (allowance type CD)
> award transport payments (allowance type AD)
> laundry (allowance type LD)
> overtime meal allowance (allowance type MD)
> domestic or overseas travel (allowance type RD)
> tool allowances (allowance type TD)
> qualification and certification allowances (allowance type QN)
> task allowances (allowance type KN)

Pre-Activation Default:
OTE? ‘Yes’ will be set to STP Payment Type Gross.
OTE? ‘No’ will be set to STP Payment Type Overtime
If the above doesn’t match your setup or you need to configure a rate line to a different STP
Payment Types then it must be changed manually in the above screen after pre-activation.
If you require to make bulk changes to any of this configuration you can contact support to explore if
automatic changes can be made during this pre-activation process.
WorkDESK – STP Phase 2.docx

Page 17

WorkDESK
STP Phase 2 Manual
Online Backup

The online backup now requires a Zip Online backup file name. This previously was optional but now
mandatory and this option will always be ticked.
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Activate STP2
Once you’ve confirmed your pre-activation configuration you can Activate STP 2 which will allow you
to start reporting STP 2 information to the ATO. WorkDESK will continue to report STP 1 until this
STP 2 activation is done.
Ensure you have no Outstanding Submissions in Accounting -> Single Tough Payroll before activating.

1) We recommend having all other users logged out for the duration of activation.
Perform a zip online backup.
Go into System -> System Control -> Maintain System Control File -> Company Information

Press Enable STP2. Activation should occur quickly.

And Press Ok.
Log out of WorkDESK.
Repeat this step for every WorkDESK database you require to report STP 2 information.
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You can confirm activation was completed by going into Accounting -> Single Touch Payroll.

The Highlighted area next to Create Update file should read STP 2 Live M2M for STP2 activated
systems.
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Other updates to the system
After STP2 Pre-Activation you will see new fields on the Employee, Rate Books, Allowances and
Billing Multipliers. You’ll need to keep these in mind when doing your daily processing.
Beyond these changes there are no other changes to the STP Payrun procedure in WorkDESK. Your
payrun still produces a file to send to the ATO that you submit in Accounting -> Single Touch Payroll.

Employee View
The Single Touch Payroll tab in the Employee shows key information about the Employee STP
information.

STP Main view
This screen reflects the ID of the Employee that will be used in STP submissions and date last
changed (if any).

The Main screen will display the employees ‘STP-ID’, this is a unique ID for each employee file that is
required when reporting to the ATO.
There is no longer a requirement to maintain a Working Holiday Maker from this screen. It is now
controlled on the Employee -> Taxation screen.

WorkDESK – STP Phase 2.docx

Page 21

WorkDESK
STP Phase 2 Manual
STP Other view

Termination will display a line for any termination pays paid to this employee.
Year to date amounts for the current year only will display underneath for FBT and Super (Super
Guarantee, Salary Sacrifice as Reportable & Super OTE year to date).
You have the drop-down option to change the Year for STP reported Terminations as well as Income
Types.
Any detected income types in the year will be visible in the drop down. E.g. if WHM and SAW were
paid in the same year for an employee then both options are available in the drop down.

STP Year to Date View
This screen reflects the STP2 component values. This includes the Total Gross as well as
Disaggregated Gross & any other values that contribute to the Total Gross.

You have the drop-down option to change the Year for STP reported components as well as Income
Types.
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STP Allowances view

The top view will display a Year to date for all reportable allowance types for this employee.
The table will list a separate item for each ‘other’ type allowance code that doesn’t fall into the
above categories.
You have the drop-down option to change the Year for STP reported Allowances as well as Income
Types.

STP Previous Years

Prior year STP1 reportable figures can be viewed in this screen.
The ‘Year’ drop down box lets you select which Year Ending to view.
All STP2 years will be available in the year to Other, Year to Date or Allowances tabs in the Year drop
down, so this screen only includes STP1 related information.
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Employee Maintain
STP Main

‘Changed since last upload’ is a flag to include the employee in the next update File to update their
information with the ATO, this should only be changed if you need to include/ exclude the employee
in the next submission.
The system will automatically handle if changes were made to the employee that require an update
to the ATO (e.g. you process a super adjustment, change an allowance type, change their YTD’s, etc).

STP Other

FBT and Super YTD values can be changed here, however super changes here will not show on the
Super Ledger and other super report (only on the information sent to the ATO).
You should continue to only make super changes via a Super Adjustment in Accounting -> Payroll as
this will reflect on the employee super ledger and this STP YTD screen.
You may need to login as 30/06/yy on the WorkDESK login screen to modify all fields.
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Employee Tax File Number
An Employee must have a valid TFN otherwise the Employee record will be rejected by the ATO. If
you did not receive a TFN from the Employee via Tax File Number Declaration you must use one of
the following TFN’s:
TFN
000000000

111111111
333333333
444444444

987654321

ATO Description
Where the payee has not completed a TFN declaration, the payee has completed a
TFN declaration and chooses not to quote a TFN, the payee has indicated that they
applied or enquired about a TFN with the ATO and failed to provide a TFN within 28
days.
Where the payee has not provided a TFN but they indicate on the TFN declaration
that they have applied or enquired about a TFN with the ATO.
Where the payee is under the age of eighteen and earns $350 or less weekly, earns
$700 or less fortnightly or earns $1517 or less monthly.
Where the payee is a recipient of a social security or service pension or benefit (other
than Newstart, sickness allowance, special benefits or partner allowance) an
exemption from quoting a TFN may be claimed.
Where a payee has quoted a TFN with alpha characters the code 987654321 must be
used in place of the quoted TFN. This code must also be used where the TFN quoted
cannot be contained in the TFN field.

For employment termination payments, in the event the payment is due to the death of an
employee, show either the TFN of the trustee for the deceased estate or the TFN of the dependant
or non-dependant of the deceased employee, whichever is applicable.

Employee Leave Payments – Leave Type
When making Leave Payments to employee there are drop-down options for Annual Leave, RDO and
Long Service Leave Payments for you to define if it is for Leave Taken or a Cash Out.
In File -> Employee -> Enter/ Alter Allowance/ Deductions:
A010 – Annual Leave:

Leave Taken or Cash Out
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A020 – Personal Leave:

Personal or Carer for Leave Taken
Compassionate Expensed for Cash Out
A030 – Long Service Leave:

Leave Taken or Cash Out
A150 – RDO Payment:

Leave Taken or Cash Out

Employee - Lump Sum A
Lump Sum A payments are used by terminating the Employee with an A070 allowance code.

T for Termination
R for Redundancy
Un-used leave will be paid and recorded automatically as their correct STP2 types based on the
current employee leave balances.
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Payroll Parameters
An update to the Tab in Accounting → Payroll → Payroll Parameters → Single Touch Payroll. This
screen records the Allowance Codes that you will define to record additional payment type. These
types come under the ATO heading Employment Termination.

Lump Sum W
New - Return to Work Payment – you are only required to setup this allowance if you need to make
a Lump Sum W Payment to an employee.
Go into Accounting -> Payroll -> Allowances and setup a new allowance code. E.g:

Can be any allowance code >199. Suggested A995
Taxable: Yes
STP Payment Type: Not Required/ Not Reportable
Accounting -> Payroll -> Payroll Parameters -> Single Touch Payroll: Lump Sum W – Taxable Column
input your Lump Sum W allowance code.
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Employment Termination types
If you have already added termination allowances for STP 1 you’re not required to re-setup these
allowances, they will be re-used for STP 2.
This document is not to be taken as Tax Advice. You must seek independent advice regarding all
matters of Taxation. Some information is readily accessible from the ATO Website (at the time of
publication) https://www.ato.gov.au/Individuals/Working/Working-as-an-employee/Leaving-yourjob/Employment-termination-payments/
Add new Allowance Codes for each of these types in the range A200 to A599. Select Accounting →
Payroll → Allowance.
This is an example of the first code you will need to set up:

After you have created the Allowance Codes enter the Allowance Codes in the table in Payroll
Parameters → Single Touch Payroll.

WorkDESK – STP Phase 2.docx

Page 28

WorkDESK
STP Phase 2 Manual
To pay a value of ETP to an Employee enter the Allowance in File → Employee → Enter/Alter
Allowance/Deduction.
The following ATO notes have been extracted from the Single Touch Payroll information provided by
the ATO. Create two sets of Allowances: Taxable and Tax-free.
Calculation of ETP Tax requires careful reading and understanding of the Tax Rules and Regulations.
If you are not familiar with this, you must consult with your external Accountant or Tax Advisor to do
the calculations for you. When entering the data in the appropriate Allowance Code, if there is a
Taxable value being paid, you must enter into the Tax field the value of the tax that is to apply to this
component.

Description
Termination Payment (R)

Other ETP not described above (in R)

ETP code O payment received (S)

ETP code O payment received (P)

Death benefit ETP paid (D)
Death benefit ETP paid (B)

Death benefit ETP paid (N)
WorkDESK – STP Phase 2.docx

ATO note
ETP made because of one of the following: early
retirement scheme, genuine redundancy,
invalidity, or compensation for personal injury,
unfair dismissal, harassment, or discrimination.
Other ETP not described by R (for example:
golden handshake, gratuity, payment in lieu of
notice, payment for unused sick leave, or
payment for unused rostered days off).
ETP code R payment received in the current year
and received another ETP (code R or code O), or
a transitional termination payment, in an earlier
income year for the same termination of
employment.
ETP code O payment received in the current year
and received another ETP (code R or code O), or
a transitional termination payment, in an earlier
income year for the same termination of
employment.
Death benefit ETP paid to a dependant of the
deceased.
Death benefit ETP paid to a non-dependant of
the deceased and a termination payment was
made to the non-dependant in a previous
income year for the same termination.
Death benefit ETP paid to a non-dependant of
the deceased.
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Death benefit ETP paid (T)
Non-Taxable FBT

Death benefit ETP paid to a trustee of the
deceased estate.
This is the grossed up year to date exempt total
of the fringe benefits provided to a payee by an
exempt Payer in the fringe benefits tax (FBT)
year (1 April to 31 March).

Payroll Reports
During the payrun you will notice an updated reports Exporting to Excel. This is to assist you with
checking and balancing your current payrun to the Year to Date figures that are being reported to
the ATO.
The reports also include some ATO terminology which should help you track where some of the
information comes from should your submission or any part of it be rejected by the ATO.
Allowance/Accrual Inconsistencies
During the start of the payrun WorkDESK will try to detect if any mandatory fields are missing for
STP reporting (e.g. invalid TFN, missing address, etc).

It will report which items are incorrect for which employees.
In this example employee BANKKJ has a state missing on their address which is required by the ATO
for STP reporting. The state field must be updated on this employee before the payrun can continue.

Initial Employee STP2 Payroll Event Year to Date - Report

This report will export to Excel in a new window at the beginning of each payrun and after the
payrun is updated it will be saved into Admin Manager under the Payrun ‘Audit’ button.
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This report is structured in a similar way to the data that is sent to the ATO via the STP transmission.
It is useful to help see how the WorkDESK fields translates to the ATO’s fields, and can be used to
help balance against other WorkDESK reports or as an initial check at the start of the payrun.
If anything is incorrect on this report you can easily cancel the payrun and make amendments before
re-running the pays.
An employee can appear twice in this report if they have more than one income stream type paid in
a year. E.g. a WHM type employee gets residency and becomes SAW. Then they would have one line
for their WHM pays and another line for their SAW pays. This is displayed in column W.
Column Z is a Total Gross, which is a total for all the represented ‘Disaggregated Gross’ components
in columns AA to AJ.
Columns AK to AR are the ATO Defined Allowances. Any ‘Other’ type defined allowances will follow.
Further columns include Redundancies, ETP’s and Lump Sum payments.

STP Audit File
During the payrun, after the pay advices print and before you can first sign off on the payrun, the
same report will open in Excel, which contains all the information being reported to the ATO.

This report is intended to be a check list for you to view that all the employee’s details and pay items
are correct before singing/ declaring to the ATO that this information is correct.
If anything is incorrect or requires adjusting you can cancel the payrun at this point and make any
amendments required.

YTD Detail Report
You can check all employee’s YTD details by using the ‘YTD Detail Report’ in Accounting -> Payroll ->
Single Touch Payroll: YTD Detail Report

The report will be presented in the exact format as the payrun report. No copies of this report are
saved/ must be saved manually if you want to retain a copy but can be created at any time.
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Create Update File with Current YTD STP 2 Information
The ATO recommend you submit an Update file after activating before you submit your first payrun.
If you are under time pressure to run your first payrun you can do so first & run this ‘Update file’
after your first pay/s, but it should be done at the earliest time possible.
Completing this process will update the ATO with all the employee’s STP2 generated data.
This process only needs to be completed once per active database after you’ve confirmed your
setup.
1) Mark all Employees for update: go into Accounting -> Payroll -> Single Touch Payroll: and
press ‘Mark All For Update’.

Answer ‘Yes’ if you are ready and a backup will automatically be created.
2) Go into Accounting -> Single Touch Payroll: Press ‘Create Update File’

Confirm the Financial year is correct (exit and login with a current year date if it is not).
Confirm the consultant detains and continue.
You must read and confirm the details about to be prepared to send to the ATO are correct.
To assist with this approval, an Excel Spreadsheet will be generated contain the full
information that is to be approved. We recommend you save the file.
3) Send the File:
Continue to sign, update and send the file as you had in previous submissions. Refer the next
section ‘Create Update File’ if you require full instructions
WorkDESK – STP Phase 2.docx
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No Changes between STP and STP2 from this section onward
The remaining sections of this document are the same processing between STP and STP2.

Create Update file
Found in Accounting → Single Touch Payroll screen at any time you need to produce a file containing
changed employee information click the button indicated in the left-hand screen.
If any condition in any employee file exists that will generate an error if sent to the ATO, a popup
message will alert you to the Employee, and indicate the reason for the process stopping. Note the
details, close message box and select File → Employee and correct the issue. In this case the
Employee does not contain a correct address.

If there are no validation errors, the system will display a screen identifying the person making the
file.
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Identify the operator who will submit the file

Signing the file
•

The operator must read and confirm the details about to be prepared to send to the ATO are
correct. To assist with this approval, an Excel Spreadsheet will be generated contain the full
information that is to be approved. We recommend you save the file.

•

Enter the password authorising you to use the selected Machine Credential and select the
statement to acknowledge you agree that you are making the declaration.
Or use the second part of the form to sign the file with different credentials than the
currently signed in Operator/Consultant.
Click Continue to move to the next step in the process.
The system will verify that the password matches the Machine Credential and if approved
will then commence an automatic backup of the data.

•
•
•
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•

The file is prepared at this point and the following screen presents this (and any other) file
waiting for transmission to the ATO.

Send a file to the ATO
•
•

Select Accounting → Single Touch Payroll.
Files must be sent to the ATO in the order they were generated.

•

Note in the example above, the date/time for the second and third entries background is in
a highlight colour. You will not be able to send either of these items until the first one has
been successfully transmitted.

WorkDESK – STP Phase 2.docx

Page 35

WorkDESK
STP Phase 2 Manual
•
•
•
•
•

•

•

•

If you select an item that is not permitted to be sent, the Send button is deselected.
Select the file at the top of the screen.
Information will display in the lower half of the screen, showing Employee Code and Status
of the record. “Outstanding” indicates the record has not been submitted.
Click Send
An automatic Online Backup will be performed. When completed the system will commence
transmission. Internet connection is required.

Messages will display on the command window. These messages may show the word ‘error’
and the system will take varying amounts of time to make the submission depending on the
status of the internet, the size of the file the status of the ATO Systems.
For busy periods this may take up to 10 minutes to receive a response from the ATO – you
must keep this window opened until the process has finished. Do not minimize the
WorkDESK screen or click away to another screen until the submission completes.
You must process only one Submission from your office at a time
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•
•

Read the Submission Results. If you get Transmission Successful, click Close. Please consult
the section Transmission Errors if the transmission was not successful.
The screen will change indicating those records that are now ‘Done’ or updated to the ATO.
Rejections for any reason will require investigating.

Transmission Unsuccessful – No Transmission Result
In this case the entry is moved from the Submit to Outstanding Submissions screen.
•
•

This can happen if the ATO Server is taking too long to respond.
The task of transmitting your PayEvent to the ATO is not complete until the ATO give back
their result of your submission.

The top of the submit screen will now include the following icon:

Outstanding Submissions
Open the Outstanding Submission screen. We recommend that you check this screen at least once a
week and make sure all submissions have been successfully processed.
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•
•
•
•
•

Observe the Status of the item is showing ‘Sent’.
Click on the Date in the top grid and click Retrieve button
After the automatic backup is complete the system will attempt to retrieve the status from
the original submission.
If this is still unsuccessful the package will remain in the Outstanding Submission screen. Try
again after waiting – suggest 30 minutes for the second retry. Keep retrying until successful.
When the result packet is retrieved, the Pay Event item will be moved back to the Submit
tab.
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Transmission Result – Partial
If the PayEvent was partially successful, the ATO will accept the employee sections that were correct
and reject the remainder. The transmission result screen will show:

•
•

•

In the above example, the information of the two employee records that were rejected
show in the bottom section of the screen.
It is possible to double click on each of these entries in turn and read the full information
packet returned by the ATO, we recommend that you click the Close Button to return to the
main STP transmission screen.
This is an example of what you will see:
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•

If you double click on the Status message of the first record you will see all of the text in the
message returned from the ATO. Here is this example where address line 1 of the employee
is blank

•

Close the message screen. Now place the cursor on the employee code and double click and
select Maintain. Address line 1 is blank. Correct the address and save. When you Exit you will
return to the Transmission screen.

•

As we have now rectified the fault with the data that caused the rejection of the employee
record, we can now click in the square beside the code signifying that this record is now
ready for another transmission.
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•
•

The second rejection in our example has a problem with the Tax File Number.
Fix all errors, clicking beside the code to record the item has been fixed. Your screen will look
similar to this.

•
•

Now click Update.
A spreadsheet containing the information that is about to be submitted will be generated
permitting the holder of the Machine Credential to verify the information that is about to be
submitted.
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•

You will be presented with the Signature screen and once the password has been verified an
automatic backup will commence followed by the transmission to the ATO, followed by the
Transmission Result screen.
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Transmission Result – Rejected
In a PayEvent, the first section of the information sent to the ATO is the PayEvent, followed by the
PayEventEmp, or Employee sections, one for each employee included in the Payrun.
In the event there is an error in the first packet the complete transmission will be rejected.

Stop all processing if this condition is encountered. Report the circumstances to WorkDESK Support
for detailed investigation.
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Correcting Payroll mistakes
The ATO publishes a guideline on this web page:
https://www.ato.gov.au/Business/Single-Touch-Payroll/In-detail/Single-Touch-Payroll-employerreporting-guidelines/?page=5#Correcting_information_reported_through_STP
For your convenience, this section contains the information from the web site at the time we
created this manual.

Correcting a pay event report
You have a period of time to correct information reported in a pay event without being liable to a
penalty for making a false or misleading statement. We call this correction a 'fix'.
If you do not make a fix within the required period, you may be liable to a penalty.

Correcting employee information
If the employee year-to-date information you last reported to us does not reflect the information in
your payroll system, you should submit the updated information to us either:
•
•

within 14 days of the need for a correction being identified
in the next regular pay event where the affected employee(s) have continuity of
employment.

If we send an error message to you relating to the employee data you have reported the same 'fix'
rules apply to correcting those errors as above.

Overpayment identified within the same financial year
Where an overpayment is identified in the same financial year it was paid, the employee will only
need to repay the net amount of the overpayment. The net amount is the amount received by the
employee.
You will need to ensure we have the correct amounts recorded (the employee's year-to-date values
do not include details of the overpayment). You can make these fixes in either:
•
•

the next regular pay cycle report for the employee (by reducing the employee's year-to-date
figures and your employer-level gross payment and withholding figures)
an update event, within 14 days of the overpayment being identified.

Misclassification
A misclassification is when information has previously been reported under an incorrect item. For
example, a payment was reported as Gross instead of as an Overtime, and no additional payment is
made to the employee.
You can make this fix in the next pay event or use an update event.
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Reporting under an incorrect ABN or PAYG withholding branch
You must correct your employees reported under an incorrect Australian business number (ABN) or
PAYG withholding branch. To fix this, you should report your employee under the correct ABN or
PAYG withholding branch from the point you discovered the error and adjust any incorrectly
reported amounts from the incorrect ABN or PAYG branch.
You can make these adjustments in the next pay event or using an update event. If the adjustment
moves PAYG withholding amounts between ABNs or branches you may need to revise activity
statements.

Out of year fixes
Prior year adjustments must be made with a backup of the prior year data copied to a new
WorkDESK group and be processed separately. This ensures your current year process is not affected
and the prior year fixes can be made without interrupting any current payroll processing.

STP Standard Payroll Procedures
After activating STP and setting up WorkDESK for STP there are procedures you’re required to follow
each time you process a payrun in WorkDESK to ensure you’re always submitting the most up to
date and correct information to the ATO.
You should follow these steps for every payrun once and add these steps to any existing internal
processing documentation you may have for processing payroll.

1) Payrun Report Pre-Check
When the payrun first starts you should receive a report exported to Excel giving you a list of all the
employees and their year to date pay items that are linked to Single Touch Payroll.
You can discard this report once you have reviewed.

2) Payrun Report Final Check
Before the end of the payrun the same report will export to Excel with a line-by-line entry of the
employee’s information being sent to the ATO.
This is the final confirmation that you have the employee’s details correct before going to the next
step.
You are not required to save this report, it will automatically save in Admin manager during the
payrun update.
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3) Machine Credential Declaration

During the payrun update you will have the option to sign off the payrun by using the declaration
options 1, 2 or 3.
1) Sign with the current logged in consultant Machine Credential
2) Sign with another consultant code Machine Credential (input the consultant code in the
‘Consultant’ box)
3) Skip signing at this stage – this will require signing to occur at the time of submission (after the
payrun)
You can also choose to cancel the payrun at this stage.
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4) ‘Submit’ the Payrun to the ATO
We recommend submitting the pay info to the ATO immediately after the payrun. The ATO state
that you must send the Single Touch information on or before the day you pay the employee.
In Accounting -> Single Touch Payroll

Highlight the outstanding payrun and press ‘Send’
This process can take up to 10 minutes to complete depending on the traffic/ load of the ATO
servers.
If you have more than one outstanding payrun (that has not been submitted to the ATO) this must
be sent first. Newer payruns that require old payruns to be sent first will be highlighted in red in the
Date column.

5) Receiving a Response from the ATO or amending response errors
Once the payrun data is sent you should receive a response from the ATO within a few minutes.
A “Transmission Successful” response, which means everything was received OK from the ATO and
you are finished submitting the pay to the ATO (can continue your regular processing).
However, if you receive a Transmission Partial or Transmission Rejected you should attend to this
before continuing. This may result in the need for you to amend items or individual records before
you can re-send the payrun.
Please see the section ‘Send a file to the ATO’ for more details or Partial and Rejected Transmissions.
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